Meta Question

ezraglenn's avatar

What's wrong with Fluther?

Asked by ezraglenn (3487points) August 25th, 2008

Every couple clicks I get a page of code instead of Fluther. I have to refresh a few times to get back here. What’s up?

this is the text that shows up:
MOD_PYTHON ERROR

ProcessId: 17757
Interpreter: ‘www.fluther.com’

ServerName: ‘www.fluther.com’
DocumentRoot: ’/var/www/’

URI: ’/browse/foryou/’
Location: ’/’
Directory: None
Filename: ’/var/www/browse’
PathInfo: ’/foryou/’

Phase: ‘PythonHandler’
Handler: ‘django.core.handlers.modpython’

Traceback (most recent call last):

File ”/usr/lib/python2.5/site-packages/mod_python/importer.py”, line 1537, in HandlerDispatch
default=default_handler, arg=req, silent=hlist.silent)

File ”/usr/lib/python2.5/site-packages/mod_python/importer.py”, line 1229, in _process_target
result = _execute_target(config, req, object, arg)

File ”/usr/lib/python2.5/site-packages/mod_python/importer.py”, line 1128, in _execute_target
result = object(arg)

File ”/usr/local/lib/python2.5/site-packages/django/core/handlers/modpython.py”, line 189, in handler
return ModPythonHandler()(req)

File ”/usr/local/lib/python2.5/site-packages/django/core/handlers/modpython.py”, line 153, in __call__
self.load_middleware()

File ”/usr/local/lib/python2.5/site-packages/django/core/handlers/base.py”, line 34, in load_middleware
mod = __import__(mw_module, {}, {}, [’’])

File ”/usr/local/lib/python2.5/site-packages/panda/main/middleware.py”, line 10, in <module>
from panda.main.alert import get_alert_numnew

File ”/usr/local/lib/python2.5/site-packages/panda/main/alert.py”, line 11, in <module>
from panda.main import inbox, activity, profile, utilities

File ”/usr/local/lib/python2.5/site-packages/panda/main/profile.py”, line 15, in <module>
from panda.main.vote import create_scoreitem

File ”/usr/local/lib/python2.5/site-packages/panda/main/vote.py”, line 24, in <module>
staff_email = [s.email for s in staff]

File ”/usr/local/lib/python2.5/site-packages/django/db/models/query.py”, line 78, in _result_iter
self._fill_cache()

File ”/usr/local/lib/python2.5/site-packages/django/db/models/query.py”, line 490, in _fill_cache
self._result_cache.append(self._iter.next())

File ”/usr/local/lib/python2.5/site-packages/django/db/models/query.py”, line 162, in iterator
for row in self.query.results_iter():

File ”/usr/local/lib/python2.5/site-packages/django/db/models/sql/query.py”, line 200, in results_iter
for rows in self.execute_sql(MULTI):

File ”/usr/local/lib/python2.5/site-packages/django/db/models/sql/query.py”, line 1465, in execute_sql
cursor = self.connection.cursor()

File ”/usr/local/lib/python2.5/site-packages/django/db/backends/__init__.py”, line 33, in cursor
cursor = self._cursor(settings)

File ”/usr/local/lib/python2.5/site-packages/django/db/backends/mysql/base.py”, line 188, in _cursor
self.connection = Database.connect(**kwargs)

File ”/var/lib/python-support/python2.5/MySQLdb/__init__.py”, line 74, in Connect
return Connection(*args, **kwargs)

File ”/var/lib/python-support/python2.5/MySQLdb/connections.py”, line 170, in __init__
super(Connection, self).__init__(*args, **kwargs2)

OperationalError: (1129, “Host ‘taurus.fluther.com’ is blocked because of many connection errors; unblock with ‘mysqladmin flush-hosts’”)

Observing members: 0 Composing members: 0

37 Answers

shrubbery's avatar

It’s happening for me too. I left a message for Andrew in the chat room. Ah well, just keep refreshing until he can sort it out :)

urgh I had to try like 3 times before it would let me answer this Q

osullivanbr's avatar

OMG It’s the government. RUN!!!

cheebdragon's avatar

“Big Brother”

joeysefika's avatar

Yea same for some people im getting ”<user>‘s avatar” instead o

cheebdragon's avatar

I get a bluebox with a ? In the middle of it…..

hi joey!

delirium's avatar

goes off and tells andrew

swimmindude2496's avatar

I have that tooooo!!!! Its flippin annoying!

Larssenabdo's avatar

happy to know it is not just me

swimmindude2496's avatar

That is how I feel. And sometimes When I try and click answer it sometimes has problems sending it to the server. Anyone else???

crunchaweezy's avatar

“Oops. We had trouble talking to the server. Please try again.”

osullivanbr's avatar

Please contact the server administrator, admin@fluther.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

That’s what my iPhone just spat at me, looks like it was my fault.
Sorry ‘bout that. Tee Hee.
Ah the things we do to entertain ourselves in these bad times

eambos's avatar

I keep getting “500 Internal Server Error.”

This is annoying.

robmandu's avatar

< < can’t wait to see the LOLcat: IM IN UR FLUTHER. ANSWERIN UR QUESTIONS.

marinelife's avatar

Does this mean we have to wait three hours until they get up out there? Must Fluther. Please fix.

robmandu's avatar

I see Andrew in the WH, but no action… so I think you’re likely right.

robmandu's avatar

Y’know, if I had to guess, it looks like one of their hosting servers is kaput. So far, whenever a page errors out for me, the last line is consistently:

Host ‘taurus.fluther.com’ is blocked because of many connection errors

Pages that appear to load okay come from davinci . fluther . com. And no problem with iceberg . fluther . com that I’ve noted yet, either.

In short, this hopefully will be a quick fix.

scamp's avatar

We will just have to be patient and wait until the guys get up. Sheesh, they have to sleep sometime. Luckily, I have my job to keep me busy while I wait.

delirium's avatar

Working on trying to get a hold of someone…

wildflower's avatar

In the meantime, I found this work-around fairly stable:

When the error page appears, hit the reload button and it brings up the page – occasionally have to hit it twice, but mostly just the one time.

Placing the cursor at the end of the URL and hitting enter doesn’t do it – just brings the error page again

I’m running Safari in Leopard

robmandu's avatar

Just guessin’ again… but the “www” is just an alias that redirects the user to either “taurus” or “davinci”. The redirect appears to be simply random in order to act as a basic load distributor. And there certainly doesn’t appear to be any established failover procedure in play.

Point is, due to the random nature of the redirect (like flipping a coin to to send you to either davinci or taurus on each page request), it’s tricky to establish any other rhyme or reason as to what works. Example: I am able, on occasion, to hit Enter at the end of the url and get a successful reload.

andrew's avatar

One of our webservers lost its database connection this morning (so our failovers weren’t triggered). It’s fixed now, but we’ll be working to make sure that if it happens again, it won’t interrupt service.

Sorry about that folks.

In the meantime…cuteness.

osullivanbr's avatar

Awww.

All is well with the world again.

JackAdams's avatar

Maybe someone who got suspended or banned, planted a virus on the website to “get even.”

It’s been done before, to other websites by disgruntled former members.

August 25, 2008, 11:43 AM EDT

intro24's avatar

Python FTW… or the lose in this case. Anyway, the mobile iPhone version works fine.

wilhel1812's avatar

Just some server problems…

eambos's avatar

Teh internets have been saved!

andrew's avatar

@intro24: Well, more like MySQL FTW, but. Anyway.

scamp's avatar

Thanks for fixing it so quick Andrew!

ezraglenn's avatar

yay fluther!

ninjaxmarc's avatar

woohoo for technical support.

timothykinney's avatar

This is an attempt by the founders of Fluther to find other people who know how to support Python and Django in order to grow the service team and make Fluther even better.

Smart move, guys.

Mitsu_Neko's avatar

whoever finds the Fluther lolcat send me the link in a message. I collect those lil cuties

Mitsu_Neko's avatar

thanks robamndu

eambos's avatar

Has fluther been running slow today for everyone, or is it just me?

Other pages load at normal speeds.

Knotmyday's avatar

I’m for more cuteness.

And yes, for the past few days, sluggish. I thought it was just the spyware on my computer.

swimmindude2496's avatar

Nope mine is running fine. Odd maybe it has to do with the error from the other day???

Answer this question

Login

or

Join

to answer.
Your answer will be saved while you login or join.

Have a question? Ask Fluther!

What do you know more about?
or
Knowledge Networking @ Fluther