Send to a Friend

Theotherkid's avatar

A question about PSP emulation...

Asked by Theotherkid (884points) July 11th, 2009

Is UMDLoader (v0.8) compatible with ChickHEN v2?
I’m using a phat PSP with 5.03 (ChickHEN v2) firmware.

Using Fluther

or

Using Email

Separate multiple emails with commas.
We’ll only use these emails for this message.