General Question

Fred931's avatar

Why won't Spore work on my friend's laptop?

Asked by Fred931 (9429points) March 14th, 2010

One of my friends came over to my house and asked me to install Spore on his laptop. It is a Dell Studio 15-something from about a year ago running Windows Vista Home Premium 32-bit. After successful installation, the program won’t run. The autoplay window does not show and nothing else happens. Is there some sort of conflict between programs causing this and how can I fix it?

I’m busy working on a project elsewhere, so please talk in simple words.

Observing members: 0 Composing members: 0

3 Answers

dpworkin's avatar

There may be a video-driver problem. I would first check the Spore literature to see if there are any known driver issues. You may be able to upgrade the driver. This is not as the entire answer, it’s just the first educated guess. I think it’s worth investigating.

Bugabear's avatar

I agree with @dpworkin. Most likely a driver problem. However Spore sometimes doesnt work on Vista for unknown reasons. When you installed it did you also install the EA download manager? If you did try updating it.

Jerikao's avatar

Given that it is a Dell laptop, it may well have an integrated video card. Most integrated video cards do not support the level of rendering required by Spore. I had that problem, myself with my little Acer. I’ll be upgrading to a desktop as soon as I can, honestly. It’s easier to get a decent desktop for a good price, as well as upgrade it as technology progresses. The problem with laptops is that they are more pricey and more difficult to upgrade (if you can upgrade at all).

Answer this question

Login

or

Join

to answer.

This question is in the General Section. Responses must be helpful and on-topic.

Your answer will be saved while you login or join.

Have a question? Ask Fluther!

What do you know more about?
or
Knowledge Networking @ Fluther