General Question

reijinni's avatar

Why does my monitor goes blank after a few minutes?

Asked by reijinni (5365 points ) December 15th, 2010

When I use Linux on my my Dell Studio XPS 435T/9000, the screen goes blank after several minutes. This only happens when I use Linux, not Windows. All I know right now it’s not a monitor problem since I used the same monitor on another setup and it worked fine.

Observing members: 0 Composing members: 0

12 Answers

Tropical_Willie's avatar

I’m not the expert but you might have a driver problem for the monitor with Linux. Check for drivers for the specific monitor.

the100thmonkey's avatar

At first I thought the question was ”[w]hy does my mother go blank after a few minutes?”

Then I LOLed.

The PC power management/display settings are probably set to lock the screen after a few minutes. If you don’t have a screensaver selected, you get a blank screen.

Which distro, btw?

reijinni's avatar

@the100thmonkey: didn’t matter because it happened with several distros: Kubuntu, Aptosid and Linux Mint.

koanhead's avatar

What do you have to do to make the monitor work again? Does it come back to life if you move the mouse or type?

Power management default for putting the screen to sleep is 5 minutes IIRC. This should be distribution-independent as I’m pretty sure it’s an Xorg setting. In GNOME look under System->Preferences->Power Management or run “gnome-power-preferences” from a terminal.

gambitking's avatar

Is it plugged in? Okay plug it in…... you should see the words “Mr. 3000” on the screen.

Okay sorry I had to do the reference. It’s possibly your VGA / PS2 cable or port. Also, if you’re using an adapter for either of those connectors, they are especially buggy.

Furthermore, you need a bit more troubleshooting before you can really rule out the monitor (although i doubt that’s the issue).

reijinni's avatar

@gambitking, I have used this monitor before with no issue and there is a adapter in both cases.

reijinni's avatar

Update: I’ve tried a different monitor on my system, same result. I’ll try to see if I can change the adapter.

koanhead's avatar

The fact that the problem only occurs under Linux and not Windows suggests that this is not a hardware problem but a misconfiguration. Changing the adapter is unlikely to help.
The fact that this has happened to you more than once implies that the screen comes “back to life” after going blank. How do you get it back?

reijinni's avatar

@koanhead, I rebooted. I’m also thinking of getting a HDMI cable and trying it that way.

koanhead's avatar

That might be useful. I have two identical monitors, one on VGA and one on HDMI, and they have different sleep behavior (the HDMI turns off the lamp when it goes to sleep, the VGA does not.) They both wake up from sleep, though.
This could also be related to a known issue with some video drivers. If your power management is such that the machine is going to sleep instead of just the monitor, then this could be an issue. In fact, none of my three Linux computers wake properly from sleep. It’s a common bug that occurs in both the nVidia proprietary driver and both proprietary (radeon) and open-source (ati) ATI drivers.

reijinni's avatar

I’ve tried the HDMI, monitor blanks out before bootup even finishes.

koanhead's avatar

So, the monitor goes blank before bootup finishes on HDMI but “after a few minutes” on VGA, is that right?
That’s a bizarre state of affairs. I suspect the video driver, which is hard to test when the monitor isn’t working. If you boot into a text-only mode from any of your livecds and the monitor still goes down during boot, then I’m probably wrong. You can also try adding “xforcevesa” to the kernel command line at boot. If you don’t know how to do these things, feel free to let me know and I’ll walk you through it.

Answer this question

Login

or

Join

to answer.

This question is in the General Section. Responses must be helpful and on-topic.

Your answer will be saved while you login or join.

Have a question? Ask Fluther!

What do you know more about?
or
Knowledge Networking @ Fluther