General Question

bomyne's avatar

Why is my Gigabyte uefi dual bios freezing up?

Asked by bomyne (636points) October 2nd, 2014

I just upgraded my dad’s DVD drive to a bluray drive. It was successful and the drive works. Linux Mint 16 can see the files on CDs, DVDs and Blurays. The system seems to be running perfectly until i wanted to boot a DVD. I restarted the system and hit F12 to bring up the boot menu. Menu came up just fine then it completely froze. Restarted and hit F2 this time. System setup screen came up then completely froze. I have tried both of these options several times with the same results.

The bios is a Gigabyte UEFI Dual Bios. It was working before the bluray, but i’m hoping there is a way to fix it without removing the new drive. Thanks.

I have tried the Q-Flash option too. It freezes too, which means i can’t update the firmware.

Observing members: 0 Composing members: 0

4 Answers

the100thmonkey's avatar

Might you not have knocked something loose when you had the case open?

Are all the SATA cables seated properly?

Lightlyseared's avatar

If you can’t get into bios have you tried resetting to the factory defaults?

bomyne's avatar

All the cables look fine.

How do you reset it to factory defaults?

edit – Curiously, i have noticed the drive loses power randomly at times, requiring the computer to be restarted. Is this related to the cables? I’ll have to take another look if so.

bomyne's avatar

Well, i fixed it and you are going to laugh at this. There was two wireless mouse connected to the system’s usb ports. I removed one and the bios works perfectly now. Major facepalm moment.

Answer this question

Login

or

Join

to answer.

This question is in the General Section. Responses must be helpful and on-topic.

Your answer will be saved while you login or join.

Have a question? Ask Fluther!

What do you know more about?
or
Knowledge Networking @ Fluther