General Question

Risu's avatar

Constantly disconnecting from games online.

Asked by Risu (13points) 5 days ago

I’ve been disconnecting from games for a while and it’s starting to get very frustrating. It mainly happens in MMORPG games. It happens when Im in loading screens or running around. On Elder scrolls online it’s very easy to spot because when it happens, I can’t attack but I can still run and open up my map. I just have to wait about 20–30 seconds before it actually logs me out. It can get me killed and its very annoying. My family doesn’t notice this problem as none of them play games, it’s really only affecting gaming. I’ve tried opening ports for the game and Ive reset my router but nothing seems to be working. Am I missing something? If anyone can help me, I’d be forever grateful.

Observing members: 0 Composing members: 0

3 Answers

Zaku's avatar

I’d try turning off any anti-virus software you’re running, and check your firewall settings to see if there’s a way to make an exception for the games, and/or also turn off your firewall, and see if that clears up the problem.

I’d also look at your router to see if it has any quick disconnections and re-connections (which would mess up a game but not so much a web browser).

If you’re using Wifi to connect to the router, see if the signal reception is weak where you are.

It could also be wifi interference with other devices. I have seen this when a USB wifi modem is being used on a computer – moving it to another USB port further from other devices that use wifi (e.g. USB wireless keyboard antenna) fixed that problem for me. If you can run a network cable to the router rather than use wifi, that can also improve your lag sometimes.

Could also be a wifi modem driver issue, possibly fixed by a driver update.

Could also be your ISP has something problematic – you could try calling their customer support, who could try running diagnostics and possibly fixing something on their end.

Some games and game companies also have connection tools and customer support for issues. e.g. Blizzard has https://us.battle.net/support/en/article/27780

And, welcome to Fluther!

Risu's avatar

I contacted my ISP about 10 minutes ago, the signal strength appears to be a bit smoother than it was before. An automated robot did some tests and then turned the internet off for around 10 minutes and booted it back up. Hopefully this has resolved the issue, I’m yet to try and see if I get disconnected, but If it happens again Ill be sure to try the things you’ve suggested. Thanks Zaku.

Zaku's avatar

Glad to help, and I hope that turns out to do the trick! :-)

Answer this question

Login

or

Join

to answer.

This question is in the General Section. Responses must be helpful and on-topic.

Your answer will be saved while you login or join.

Have a question? Ask Fluther!

What do you know more about?
or
Knowledge Networking @ Fluther